btrfs/048: add validation of compression options
[xfstests-dev.git] / m4 / package_dmapidev.m4
1 AC_DEFUN([AC_PACKAGE_NEED_XFS_DMAPI_H],
2   [ AC_CHECK_HEADERS([xfs/dmapi.h])
3     if test "$ac_cv_header_xfs_dmapi_h" != yes; then
4         echo
5         echo 'FATAL ERROR: could not find a valid DMAPI library header.'
6         echo 'Install the data migration API (dmapi) development package.'
7         echo 'Alternatively, run "make install-dev" from the dmapi source.'
8         exit 1
9     fi
10   ])
11
12 AC_DEFUN([AC_PACKAGE_WANT_DMAPI],
13   [ AC_CHECK_LIB(dm, dm_make_handle, [ have_dmapi=true ], [
14         have_dmapi=false
15         echo
16         echo 'WARNING: could not find a valid DMAPI base library.'
17         echo 'If you want DMAPI support please install the data migration'
18         echo 'API (dmapi) library package. Alternatively, run "make install"'
19         echo 'from the dmapi source.'
20         echo
21     ])
22     libdm="-ldm"
23     test -f ${libexecdir}${libdirsuffix}/libdm.la && \
24         libdm="${libexecdir}${libdirsuffix}/libdm.la"
25     AC_SUBST(libdm)
26     AC_SUBST(have_dmapi)
27   ])